Damaged Theta S ** 5x beep + red light


Hi everyone,

I have a Theta S (unfortunately quite new…) and was out shooting today and a gust of wind took over my new tripod and the Theta took a bit of a hit on the cement. Casing popped open but no damage to the lenses. I got everything popped back together but then the nasty 5x rapid beep and red light situation. Flashes a couple times and then the unit powers off.

Back home I am able to get access to files by holding down Wifi + shutter and then plugging it in. I updated the firmware from 1.00 to 1.21 (I think) which it says is now the newest and I deleted the folders on the Theta before rebooting hoping it would force it to reset itself. It recreated the folders but I have the same beeping issue.

I can get into a shooting mode by holding down wifi/shutter + power and the red light blinks but I’m able to get normal wifi access via my Android smart phone and see an image (but very blurry and distorted). If I try to take a photo it fails. If I turn off the unit and back on it 5x beeps/red light and then turns back off. I can only get it to stay on with the wifi/shutter + power combo.

Any ideas? Did a little gust of wind just kill my Theta? =( I’m surprised there’s no way to do a full factory reset, but I guess that’s what I get for a consumer product… And of course no warranty is going to cover this with the nice ding in the external plastic casing from the fall…

Thanks for any ideas!


We have Chrashed Thetas in this way normally you can send it for repair and get a new one at a redused price.
we got a new here for 1700 Sek swedis crones
i think the lenses also get out of focus from the crash